MySQL8.0版本和PHP7不兼容问题?

MySQL8.0版本和PHP7不兼容问题?

MySQL8.0版本和PHP7不兼容一般有两种情况:

1、主要是MySQL8.0默认是utfmb4的格式,PHP默认的是UTF8格式;

解决方法:需要将MySQL8.0默认格式设置为UTF8

微信截图_20200606135506.png

2、身份认证的加密方式不兼容导致的,MySQL8.0中默认方式为caching_sha2_password。

解决方法:

新建用老版加密方式初始化密码的用户即可:

CREATEUSERusername@localhostidentifiedwithmysql_native_passwordby'password';

然后在my.cnf中添加一行:

default_authentication_plugin=mysql_native_password;

推荐教程:《PHP教程》

以上就是MySQL8.0版本和PHP7不兼容问题?的详细内容,更多请关注龙方网络其它相关文章!

郑重声明:本文版权包含图片归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们(delete@yzlfxy.com)修改或删除,多谢。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 0 条评论)
昵称:
匿名发表
   
验证码: