php依赖包Composer的安装

这篇文章主要介绍了关于php 依赖包 Composer 的安装,有着一定的参考价值,现在分享给大家,有需要的朋友可以参考一下

1、配置PHP环境变量(不会的查阅其他资料)

2、使用在项目根目录下打开命令行

3、命令行执行操作

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"

其中

544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061

为个版本编号类的字符串

4、执行

php composer.phar

安装成功会出现命令列表

5、在项目中使用 Composer,需要一个 composer.json 文件,格式如下(具体值看情况):

{
    "name": "topthink/think",
    "description": "the new thinkphp framework",
    "type": "project",
    "keywords": [
        "framework",
        "thinkphp",
        "ORM"
    ],
    "homepage": "http://thinkphp.cn/",
    "license": "Apache-2.0",
    "authors": [
        {
            "name": "liu21st",
            "email": "liu21st@gmail.com"
        }
    ],
    "require": {
        "php": ">=5.4.0",
        "topthink/framework": "5.0.*",
        "topthink/think-image": "^1.0",
        "topthink/think-captcha": "1.*",
        "topthink/think-mongo": "1.*",
        "topthink/think-migration": "1.*",
        "topthink/think-queue": "1.*",
        "topthink/think-helper": "1.*"
    },
    "autoload": {
        "psr-4": {
            "app\\": "application"
        }
    },
    "extra": {
        "think-path": "thinkphp"
    },
    "config": {
        "preferred-install": "dist"
    }
}

6、执行

php composer.phar install

7、要是项目下已经有了composer.jsoncomposer.lock 执行

php composer.phar update


以上就是php依赖包Composer的安装的详细内容,更多请关注龙方网络其它相关文章!

郑重声明:本文版权包含图片归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们(delete@yzlfxy.com)修改或删除,多谢。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 0 条评论)
昵称:
匿名发表
   
验证码: