常见交换机术语

1.1 以太网端口配置命令 1.1.1 broadcast-suppression 【命令】 broadcast-suppression pct undo broadcast-suppression 【视图】 以太网端口视图 【参数】 pct :指定以太网端口最大广播流量的线速度百分比,取值范围为 5 ~ 100 ,缺省值为 100 ,步长为 5

1.1 以太网端口配置命令

1.1.1 broadcast-suppression

【命令】

broadcast-suppression pct

undo broadcast-suppression

【视图】

以太网端口视图

【参数】

pct:指定以太网端口最大广播流量的线速度百分比,取值范围为5100,缺省值为100,步长为5。百分比越小,则允许通过的广播流量也越小。

【描述】

broadcast-suppression命令用来限制端口上允许通过的广播流量的大小,当广播流量超过用户设置的值后,系统将广播流量作丢弃处理,从而使广播所占的流量比例降低到合理的范围,保证网络业务的正常运行。undo broadcast-suppression命令用来恢复端口上允许通过的广播流量为缺省值100,即端口上允许通过的广播流量为100%,不对广播流量进行抑制

【举例】

# 允许20%的广播报文通过,即对端口的广播流量作80%的广播风暴抑制。

[Quidway-Ethernet0/1] broadcast-suppression 20

1.1.2 description

【命令】

description text

undo description

【视图】

以太网端口视图

【参数】

text:端口描述字符串,最多为80个字符。

【描述】

description命令用来设置端口的描述字符串,undo description命令用来取消端口描述字符串。

缺省情况下,端口描述字符串为空。

【举例】

# 设置以太网端口Ethernet0/1的描述字符串为lanswitch-interface

[Quidway-Ethernet0/1] description lanswitch-interface

1.1.3 display interface

【命令】

display interface [ interface_type | interface_type interface_num | interface_name ]

【视图】

所有视图

【参数】

interface_type:端口类型。

interface_num:端口号。

interface_name:端口名,表示方法为interface_name=interface_type interface_num

参数的具体说明请参见interface命令中的参数说明。

【描述】

display interface命令用来显示端口的配置信息。

在显示端口信息时,如果不指定端口类型和端口号,则显示交换机上所有的端口信息;如果仅指定端口类型,则显示该类型端口的所有端口信息;如果同时指定端口类型和端口号,则显示指定的端口信息。

【举例】

# 显示以太网端口Ethernet0/1的配置信息。

display interface ethernet0/1

Ethernet0/1 current state : UP

IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc00-0010

Description : aaa

The Maximum Transmit Unit is 1500

Media type is twisted pair, loopback not set

Port hardware type is 100_BASE_TX

100Mbps-speed mode, full-duplex mode

Link speed type is autonegotiation, link duplex type is autonegotiation

Flow-control is not supported

The Maximum Frame Length is 1536

Broadcast MAX-ratio: 100%

PVID: 1

Mdi type: auto

Port link-type: access

Tagged VLAN ID : none

Untagged VLAN ID : 1

Last 5 minutes input: 0 packets/sec 0 bytes/sec

Last 5 minutes output: 0 packets/sec 0 bytes/sec

input(total): 0 packets, 0 bytes

0 broadcasts, 0 multicasts

input(normal): - packets, - bytes

- broadcasts, - multicasts

input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC

0 frame, - overruns, 0 aborts, 0 ignored, - parity errors

Output(total): 0 packets, 0 bytes

0 broadcasts, 0 multicasts, 0 pauses

Output(normal): - packets, - bytes

- broadcasts, - multicasts, - pauses

Output: 0 output errors, 0 underruns, - buffer failures

- aborts, 0 deferred, 0 collisions, 0 late collisions

- lost carrier, - no carrier

表1-1 端口配置信息描述表

域名

描述

Ethernet0/1 current state

以太网端口当前开启或关闭状态

IP Sending Frames' Format

以太网帧格式

Hardware address

端口硬件地址

Description

端口描述字符串

The Maximum Transmit Unit

最大传输单元

Media type

介质类型

loopback not set

端口环回测试状态

Port hardware type

端口硬件类型

100Mbps-speed mode, full-duplex mode

Link speed type is autonegotiation, link duplex type is autonegotiation

端口的双工状态和速率均设置为自协商状态,与对端协商的实际结果是100Mbit/s速率和全双工模式

Flow-control is not supported

端口流控状态

The Maximum Frame Length

端口允许通过的最大以太网帧长度

Broadcast MAX-ratio

端口广播风暴抑制比

PVID

端口缺省VLAN ID

Mdi type

网线类型

Port link-type

端口链路类型

Tagged VLAN ID

标识在该端口有哪些VLAN的报文需要打Tag标记

Untagged VLAN ID

标识在该端口有哪些VLAN的报文不需要打Tag标记

Last 5 minutes output: 0 packets/sec 0 bytes/sec

Last 5 minutes input: 0 packets/sec 0 bytes/sec

端口最近五分钟输入和输出速率和报文数

input(total): 0 packets, 0 bytes

0 broadcasts, 0 multicasts

input(normal): - packets, - bytes

- broadcasts, - multicasts

input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC

0 frame, - overruns, 0 aborts, 0 ignored, - parity errors

Output(total): 0 packets, 0 bytes

0 broadcasts, 0 multicasts, 0 pauses

Output(normal): - packets, - bytes

- broadcasts, - multicasts, - pauses

Output: 0 output errors, 0 underruns, - buffer failures

- aborts, 0 deferred, 0 collisions, 0 late collisions

- lost carrier, - no carrier

端口输入/输出报文和错误信息统计

1.1.4 display port

【命令】

display port { hybrid | trunk }

【视图】

所有视图

【参数】

hybrid:显示Hybrid端口。

Trunk:显示Trunk端口。

【描述】

display port命令用来显示当前系统是否有链路类型为Hybrid或者Trunk的端口,如果有,则显示出对应的端口名。

【举例】

# 显示当前系统存在的Hybrid端口。

display port hybrid

Now, the following hybrid ports exist:

Ethernet0/1 Ethernet0/2

以上信息表示当前系统有两个Hybrid端口,分别为Ethernet0/1Ethernet0/2

1.1.5 duplex

【命令】

duplex { auto | full | half }

undo duplex

【视图】

以太网端口视图

【参数】

auto:端口处于自协商状态。

full:端口处于全双工状态。

half:端口处于半双工状态。

【描述】

duplex命令用来设置以太网端口的全双工/半双工属性,undo duplex命令用来将端口的双工状态恢复为缺省的自协商状态

缺省情况下,端口处于自协商状态。

相关配置可参考命令speed

【举例】

# 将以太网端口Ethernet0/1端口设置为自协商状态。

[Quidway-Ethernet0/1] duplex auto

1.1.6 flow-control

【命令】

flow-control

undo flow-control

【视图】

以太网端口视图

【参数】

【描述】

flow-control命令用来开启以太网端口的流量控制特性,以避免拥塞发生时丢失数据包,undo flow-control命令用来关闭以太网端口流量控制特性。

缺省情况下,关闭以太网端口的流量控制。

【举例】

# 开启以太网端口Ethernet0/1的流量控制。

[Quidway-Ethernet0/1] flow-control

1.1.7 interface

【命令】

interface { interface_type interface_num | interface_name }

【视图】

系统视图

【参数】

interface_type:端口类型,取值为EthernetGigabitEthernet

interface_num:端口号,采用槽位编号/端口编号的格式。对于S3526S3526ES3526C以太网交换机,槽号取值范围为02槽号取0表示交换机提供的固定以太网端口,端口号取值范围为124;槽号取12分别表示后面板上两个扩展模块提供的以太网端口,端口号只能取1。对于S3526 FMS3526 FSS3526E FMS3526E FS以太网交换机,槽号取值范围为04:槽号取0表示交换机提供的固定以太网端口,端口号取值范围为112;槽号取12分别表示前面板上两个扩展模块提供的以太网端口,端口号取值范围均为16;槽号取34分别表示后面板上两个扩展模块提供的以太网端口,端口号只能取1。对于S3552GS3552P以太网交换机,槽号取值范围为01:槽号取0表示交换机提供的百兆以太网端口,端口号取值范围为148;槽号取1表示交换机提供的千兆以太网端口,端口号只能取14。对于S3528GS3528P以太网交换机,槽号取值范围为01:槽号取0表示交换机提供的百兆以太网端口,端口号取值范围为124;槽号取1表示交换机提供的千兆以太网端口,端口号只能取14

interface_name:端口名,表示方法为interface_name= interface_type interface_num

【描述】

interface命令用来进入以太网端口视图。用户要配置以太网端口的相关参数,必须先使用该命令进入以太网端口视图

【举例】

# 进入Ethernet0/1以太网端口视图。

[Quidway] interface ethernet0/1

1.1.8 loopback

【命令】

loopback { external | internal }

【视图】

以太网端口视图

【参数】

external:外环测试。

internal:内环测试。

【描述】

loopback命令用来设置以太网端口进行环回测试,以检验以太网端口工作是否正常,环回测试执行一定时间后将自动结束。

缺省情况下,以太网端口不进行环回测试。

【举例】

# 对以太网端口Ethernet0/1进行内环测试。

[Quidway-Ethernet0/1] loopback internal

1.1.9 mdi

【命令】

mdi { across | auto | normal }

undo mdi

【视图】

以太网端口视图

【参数】

across:连接网线类型为交叉网线。

auto:自动识别是平行网线还是交叉网线。

normal:连接网线类型为平行网线。

【描述】

mdi命令用来设置以太网端口的网线类型,undo mdi命令用来恢复以太网端口网线类型的缺省值。

缺省情况下,以太网交换机自动识别所连接的网线类型。

需要注意的是,该命令只对10/100Base-TX1000Base-T端口有效。

【举例】

# 将以太网端口Ethernet0/1的网线类型设置为自动识别。

[Quidway-Ethernet0/1] mdi auto

1.1.10 port access vlan

【命令】

port access vlan vlan_id

undo port access vlan

【视图】

以太网端口视图

【参数】

vlan_idIEEE802.1Q中定义的VLAN ID取值范围为24094

【描述】

port access vlan命令用来把Access端口加入到指定的VLAN中,undo port access vlan命令用来把Access端口从指定VLAN中删除。

此命令使用的条件是vlan_id所指的VLAN必须存在。

【举例】

# Ethernet0/1端口加入到VLAN3中(VLAN3已经存在)。

[Quidway-Ethernet0/1] port access vlan 3

1.1.11 port hybrid pvid vlan

【命令】

port hybrid pvid vlan vlan_id

undoport hybrid pvid

【视图】

以太网端口视图

【参数】

vlan_idIEEE802.1Q中定义的VLAN ID,取值范围为14094缺省值1

【描述】

port hybrid pvid vlan命令用来设置Hybrid端口的缺省VLAN IDundoport hybrid pvid命令用来恢复端口的缺省VLAN ID

Hybrid端口可以和isolate-user-vlan同时配置。但如果缺省VLAN是在isolate-user-vlan中建立了映射的VLAN,则不允许修改缺省VLAN ID,只有在解除映射后才能进行修改。

Hybrid端口的缺省VLAN ID和相连的对端交换机Hybrid端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

相关配置可参考命令port link-type

【举例】

# Hybrid端口Ethernet0/1的缺省VLAN设为100

[Quidway-Ethernet0/1] port hybrid pvid vlan 100

1.1.12 port hybrid vlan

【命令】

port hybrid vlan vlan_id_list { tagged | untagged }

undo port hybrid vlan vlan_id_list

【视图】

以太网端口视图

【参数】

vlan_id_listvlan_id_list = [ vlan_id1 [ to vlan_id2 ] ]&<1-10>Hybrid端口要加入的VLAN的范围,可以是离散的,vlan_id取值范围为1~4094&<1-10>表示前面的参数最多可以重复输10次。

tagged:所指定VLAN的报文将带有标签

untagged指定VLAN的报文不带标签。

【描述】

port hybrid vlan命令用来将Hybrid端口加入到指定的已经存在的VLANundo port hybrid vlan命令用来将Hybrid端口从指定的VLAN中删除。

Hybrid端口可以属于多个VLAN。如果多次使用port hybrid vlan vlan_id_list { tagged | untagged }命令,那么Hybrid端口上允许通过的VLAN是这些vlan_id_list的合集。

此命令使用的条件是:vlan_id所指的VLAN必须存在。

相关配置可参考命令port link-type

【举例】

# Hybrid端口Ethernet0/1加入到2450100 VLAN中,并且这些VLAN的报文将带有标签。

[Quidway-Ethernet0/1] port hybrid vlan 2 4 50 to 100 tagged

1.1.13 port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

以太网端口视图

【参数】

access设置端口为Access端口。

hybrid:设置端口为Hybrid端口。

trunk:设置端口为Trunk端口。

【描述】

port link-type命令用来设置以太网端口的链路类型,undo port link-type命令用来恢复端口的链路类型为缺省状态,即为Access端口。

在一台以太网交换机上,Trunk端口和Hybrid端口不能同时被设置。

缺省情况下,端口为Access端口。

【举例】

# 以太网端口Ethernet0/1设置为Trunk端口。

[Quidway-Ethernet0/1] port link-type trunk

1.1.14 port trunk permit vlan

【命令】

port trunk permit vlan { vlan_id_list | all }

undo port trunk permit vlan { vlan_id_list | all }

【视图】

以太网端口视图

【参数】

vlan_id_listvlan_id_list = [ vlan_id1 [ to vlan_id2 ] ]&<1-10>为此Trunk端口加入的VLAN的范围,可以是离散的,vlan_id取值范围为24094&<1-10>表示前面的参数最多可以重复输10次。

allTrunk端口加入到所有VLAN中。

【描述】

port trunk permit vlan命令用来将Trunk端口加入到指定的VLANundo port trunk permit vlan命令用来将Trunk端口从指定的VLAN中删除。

Trunk端口可以属于多个VLAN。如果多次使用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan_id_list的集合。

此命令使用的条件是:vlan_id所指的VLAN不是缺省VLAN

相关配置可参考命令port link-type

【举例】

# Trunk端口Ethernet0/1加入到2450100 VLAN

[Quidway-Ethernet0/1] port trunk permit vlan 2 4 50 to 100

1.1.15 port trunk pvid vlan

【命令】

port trunk pvid vlan vlan_id

undo port trunk pvid

【视图】

以太网端口视图

【参数】

vlan_idIEEE802.1Q中定义的VLAN ID,取值范围为14094。缺省值为1

【描述】

port trunk pvid vlan命令用来设置Trunk端口的缺省VLAN IDundo port trunk pvid命令用来恢复端口的缺省VLAN ID

Trunk端口不能和isolate-user-vlan同时配置

Trunk端口的缺省VLAN ID和相连的对端交换机Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

相关配置可参考命令port link-type

【举例】

# Trunk端口Ethernet0/1的缺省VLAN设为100

[Quidway-Ethernet0/1] port trunk pvid vlan 100

1.1.16 reset counters interface

【命令】

reset counters interface[ interface_type | interface_type interface_num | interface_name ]

【视图】

用户视图

【参数】

interface_type:端口类型。

interface_num:端口号。

interface_name:端口名,表示方法为interface_name= interface_type interface_num

参数的具体说明请参见interface命令中的参数说明。

【描述】

reset counters interface命令用来清除端口的统计信息,以便重新对端口进行相关信息的统计。

在清除端口信息时,如果不指定端口类型和端口号,则清除交换机上所有的端口信息;如果仅指定端口类型,则清除该类型端口的所有端口信息;如果同时指定端口类型和端口号,则清除指定的端口信息。

802.1X使能后,端口信息不能被清除。

【举例】

# 清除以太网端口Ethernet0/1端口统计信息。

reset counters interface ethernet0/1

1.1.17 shutdown

【命令】

shutdown

undo shutdown

【视图】

以太网端口视图

【参数】

【描述】

shutdown命令用来关闭以太网端口,undo shutdown命令用来打开以太网端口。

缺省情况下,以太网端口为打开状态。

需要注意的是,堆叠模块的端口不支持该命令。

【举例】

# 打开以太网端口Ethernet0/1

[Quidway-Ethernet0/1] undo shutdown

1.1.18 speed

【命令】

l 100Mbit/s以太网端口下命令形式为:

speed { 10 | 100 | auto }

l 1000Mbit/s以太网端口下命令的形式为:

speed { 10 | 100 | 1000 | auto }

l 命令的undo形式为:

undo speed

【视图】

以太网端口视图

【参数】

10:表示端口速率为10Mbit/s

100:表示端口速率为100Mbit/s

1000:表示端口速率为1000Mbit/s

auto:表示端口速率处于双方自协商状态。

【描述】

speed命令用来设置端口的速率,undo speed命令用来恢复端口的速率为缺省值。

缺省情况下,端口速率处于双方自协商状态

相关配置可参考命令duplex

【举例】

# 将以太网端口Ethernet0/1的端口速率设置为10Mbit/s

[Quidway-Ethernet0/1] speed 10


第2章 以太网端口汇聚配置命令

2.1 以太网端口汇聚配置命令

2.1.1 display link-aggregation

【命令】

display link-aggregation [ master_interface_name ]

【视图】

所有视图

【参数】

master_interface_name:汇聚端口组的主端口名,表示方式为master_interface_name= { interface_type interface_num | interface_name }其中interface_type为端口类型,interface_num为端口编号,interface_name为端口名

【描述】

display link-aggregation命令用来显示汇聚端口的相关信息。

如果指定了汇聚端口组的主端口,则显示相关汇聚端口组的信息;如果不指定汇聚端口组的主端口,则显示所有的汇聚端口的相关信息。

相关配置可参考命令link-aggregation

【举例】

# 显示主端口为Ethernet0/1的汇聚端口组的相关信息。

display link-aggregation ethernet0/1

Master port: Ethernet0/1

Other sub-ports:

Ethernet0/2

Mode: both

表2-1 端口汇聚信息描述表

域名

描述

Master port

主端口

Other sub-ports

其他成员端口

Mode

汇聚模式

2.1.2 link-aggregation

【命令】

link-aggregation interface_name1 to interface_name2 { both | ingress }

undo link-aggregation { master_interface_name | all }

【视图】

系统视图

【参数】

interface_name1:用来表示加入汇聚的起始以太网端口。

interface_name2:用来表示加入汇聚的终止以太网端口。

both:表示汇聚组中各成员端口根据源MAC地址和目的MAC址对出端口方向的数据流进行负荷分担。

ingress表示汇聚组中各成员端口仅根据源MAC地址对出端口方向的数据流进行负荷分担。

master_interface_name:端口汇聚的主端口。

all:所有汇聚端口。

【描述】

link-aggregation命令用来将一组端口设置为汇聚端口,并把端口中端口号最小的作为主端口,undo link-aggregation命令用来删除以太网端口汇聚。

需要注意的是,进行汇聚的以太网端口必须同为10M_FULL10Mbit/s速率,全双工模式)或100M_FULL100Mbit/s速率,全双工模式)或1000M_FULL1000Mbit/s速率,全双工模式),否则无法实现汇聚。

相关配置可参考命令display link-aggregation

【举例】

# 根据源MAC地址和目的MAC址对出端口方向的数据流进行负荷分担

[Quidway] link-aggregation ethernet0/1 to ethernet0/2 both

郑重声明:本文版权包含图片归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们(delete@yzlfxy.com)修改或删除,多谢。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 0 条评论)
昵称:
匿名发表
   
验证码: