双出口要作线路冗余分流的问题

双 出口 要作 线路 冗余 分流 的 问题 问题 : 有一个cisco2621, 两个ISP 提供的接入(有一些固定 IP) ,现在想让两个 线路 冗余 分流 (同时负载而且有某个 线路 故障时能自动转到另一条),而且内网有WEB 服务器要提供给外网用户访问,同时要让内网用户上网 (应

出口要作线路冗余分流问题

问题有一个cisco2621, 两个ISP 提供的接入(有一些固定 IP) ,现在想让两个线路冗余分流(同时负载而且有某个线路故障时能自动转到另一条),而且内网有WEB 服务器要提供给外网用户访问,同时要让内网用户上网 (应该设NAT),应该怎么配(策略路由+NAT+...)

解答:

1、内部上网你可以用route-map进行分流。但别人访问你就目前的状态来说是没办法分流

2、只能做分流。负载均衡在现有的环境下是做不到的。包括互为备份都做不到。

3、isp1---routerA e1
isp2 --routerA e2
routerA e3---switcher--web server and PC s
isp1 gw 10.10.10.1 e1 ip=10.10.10.10
isp2 gw 20.20.20.1 e2 ip=20.20.20.20
e3 ip=192.168.1.1
另isp 提供ip :10.10.10.9 ;20.20.20.9

web server 有两个ip 192.168.1.100, 192.168.1.101
PC s ip 192.168.1.2 ----192.168.1.50

现想web server 做静态NAT(192.168.1.100 ---- 10.10.10.9;
192.168.1.101-----20.20.20.9) 并通过isp1出去,当出现故障时转到isp2
而PC s 做PAT 通过isp2出去,当出现故障时转到isp1

router A:
int e1
ip add 10.10.10.10/24
ip nat outside

int e2
ip add 20.20.20.20/24
ip nat outside

int e3
ip add 192.168.1.1/24
ip nat inside
ip policy route-map test


rtr 1------配置SAA检查连通性。并跟踪这结果。很精巧的实现思路,最好按IP源地址进行分流
type echo protocol ipicmpecho 10.10.10.1
rtr schedule 1 life forever start-time now

rtr 2
type echo protocol ipicmpecho 20.20.20.1
rtr schedule 2 life forever start-time now

track 123 rtr 1 reachability
track 124 rtr 2 reachability

route-map test permit 10
match ip add 110
set ip next-hop verify-availability 10.10.10.1 track 123
set ip next-hop verify-availability 20.20.20.1 track 124

route-map test permit 20
match ip add 120
set ip next-hop verify-availability 20.20.20.1 track 123
set ip next-hop verify-availability 10.10.10.1 track 124

ip nat inside source static 192.168.1.100 10.10.10.9
ip nat inside source static 192.168.1.101 20.20.20.9
ip nat inside source list 120 interface e2 overload
ip nat inside source list 120 interface e1 overload

access-list 110 permit ip 192.168.1.10 0.0.0.0 10.10.10.0 255.0.0.0
access-list 110 permit ip 192.168.1.10 0.0.0.0 20.20.20.0 255.0.0.0
access-list 110 permit ip 192.168.1.9 0.0.0.0 10.10.10.0 255.0.0.0
access-list 110 permit ip 192.168.1.9 0.0.0.0 20.20.20.0 255.0.0.0
access-list 120 permit ip 192.168.1.0 0.0.0.255 0.0.0.0 20.0.0.0 255.0.0.0
access-list 120 permit ip 192.168.1.0 0.0.0.255 0.0.0.0 10.0.0.0 255.0.0.0

ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 0.0.0.0 0.0.0.0 20.20.20.1

郑重声明:本文版权包含图片归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们(delete@yzlfxy.com)修改或删除,多谢。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 0 条评论)
昵称:
匿名发表
   
验证码: