2.0版本的jquery支不支持ie8

2.0版本的jquery不支持ie8。jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理,官方只做BUG维护,功能不再新增;如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本。Jquery2.x相较于1.x没有增加什么新特性,主要是去除了ie678的支持,提升了性能,减小了体检。

2.0版本的jquery支不支持ie8

前端(vue)入门到精通课程:进入学习

本教程操作环境:windows7系统、jquery3.6.1版本、Dell G3电脑。

jQuery 是一个简洁而快速的 JavaScript 库,可用于简化事件处理,HTML 文档遍历,Ajax 交互和动画,以便快速开发网站。jQuery 简化了 HTML 的客户端脚本,从而简化了 Web 2.0 应用程序的开发。

jQuery设计的宗旨是“write Less,Do More”,即倡导写更少的代码,做更多的事情。它封装JavaScript常用的功能代码,提供一种简便的JavaScript设计模式,优化HTML文档操作、事件处理、动画设计和Ajax交互。

jQuery的核心特性可以总结为:具有独特的链式语法和短小清晰的多功能接口;具有高效灵活的css选择器,并且可对CSS选择器进行扩展;拥有便捷的插件扩展机制和丰富的插件。

2.0版本的jquery不支持ie8。

jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本。

版本描述
1.x兼容ie678,使用最为广泛的,官方只做bug维护,功能不再新增。因此一般项目来说,使用1.x版本就可以了,最终版本:1.12.4
2.x不兼容ie678,很少人使用,官方只做bug维护,功能不再新增。如果不考虑兼容版本低的浏览器可以使用2.x,最终版本:2.2.4
3.x不兼容ie678,只支持最新的浏览器。除非特殊要求,一般不会使用3.x版本的,很多老的jQuery插件不支持这个版本。目前该版本是官方主要更新维护的版本。

低版本jq在ie下不报错,高版本jq在ie下报错

2.0版本的jquery支不支持ie8

查看2.0.0的源码,只有addEventListener,显然IE不支持这个方法,IE下添加事件监听需要用attachEvent

2.0版本的jquery支不支持ie8

再看1.11.2的版本源码,有点长,做了对addEventListener的判断,不支持的话走attachEvent

2.0版本的jquery支不支持ie8

当然这只是使用高版本jq报的第一个错误,事情走到这一步就已经明了了,查看jq官网对浏览器的支持 http://jquery.com/browser-support/

我们找到这样一段话

2.0版本的jquery支不支持ie8

英语不好,拿谷歌翻译了一下 :(Current-1)和Current表示我们支持浏览器的当前稳定版本及其之前的版本。 例如,如果当前版本的浏览器是24.x,我们支持24.x和23.x版本。

总结

jQuery2.0.0版本没有attachEvent所以ie8下会报错(当然ie8下报错不止这一个原因,但这是要想修复高版本jq在ie8下报错首先要解决的问题,这回牵扯出一系列的ie8兼容问题,这些兼容问题jq1.12-已经解决了,官方推荐ie8下使用1.12还是有原因的)

以上就是2.0版本的jquery支不支持ie8的详细内容,更多请关注龙方网络其它相关文章!

郑重声明:本文版权包含图片归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们(delete@yzlfxy.com)修改或删除,多谢。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 0 条评论)
昵称:
匿名发表
   
验证码: